Warning: Illegal string offset 'html' in /home/wordmodules/cache/skin_cache/cacheid_1/skin_topic.php on line 975 tw module encoding issue - theWord Modules

Jump to content


- - - - -

tw module encoding issue


1 reply to this topic

#1 keyuhui

    New to the website

  • Members
  • Pip
  • 6 posts
  • LocationAsia

Posted 31 January 2015 - 02:52 AM

hi everyone,

I'm having trouble with certain TW modules not displaying properly. I think it's a problem with the encoding. Anyone have any ideas? For some modules, smart quotes, dashes and other marks and diacritics display as garbled Chinese text (see attached)

Just a little background on my situation...

My OS is Chinese Windows 7, but most of my modules display perfectly fine, including those with smart quotes, dashes (–), and other special symbols and diacritics., but some of my modules always display incorrectly (see above).

Some of the problematic modules include: Hasting's Bible Dictionary, and Hasting's NT Dictionary, Lange's Commentary, Church Pulpit Commentary, Bridgeway Dictionary, and several others. The modules look fine in eSword, but the counterpart modules (whether downloaded from www.wordmodules.com or converted with TW's importer tool), have the above mentioned encoding issues.

I've tried changing the Encoding settings for TW's importer tool to see if that helped, but so far it hasn't. I think the default is 1252, and I've tried 936, 54936 (both for Chinese encoding), and several others without avail.

The only option that has worked so far, is to open the eSword module with T4, save as a RTF, then open in MS Word and find/replace smart quotes, dashes, etc. Then reload in T4 and remake the module. The problem is, this doesn't solve the problem with certain words/letters with diacritics, AND some modules (like Hasting's dictionaries), won't open with T4 for some reason.

Most if not all of the modules that are causing problems were posted by Josh Bond. (By the way, I REALLY appreciate all the work you put into this website and terrific module development!) I was wondering if you might have some insight into what's causing my problem? I'm aware that you generally use T4 to make modules and then convert to TW...Do you always use 1252 encoding in the TW importer?

Any help that anyone can offer would be greatly appreciated. By the way, I am fairly certain that the problem is related to my OS, because the problem modules look find on an English OS, BUT that can't be the only problem, because other modules display fine on my system...so it seems the issue has to be related to codepage encoding (I'm really a novice with regard to encoding, but it's the only thing that makes sense to me).

Thanks to everyone.

Keyuhui

Update:

Not sure if anyone else had this issue, but I just wanted to mention that I did find a solution for this problem (thanks to the folks over at theword.net) The problem is caused in some modules that are created with NT4 (Tooltip Tool NT for eSword), when the Include RTF Header option is NOT checked. The modules look fine in eSword, but display garbled characters (at least on my Chinese-based system).

So the solution is usually to remake the module with NT4 (if possible), and make sure to check Include RTF Header

Hope that helps anyone who may have experience a similar issue.

Keyuhui

Attached Files


Edited by keyuhui, 23 February 2015 - 08:46 AM.


#2 Gerhard

    New to the website

  • Members
  • Pip
  • 3 posts

Posted 10 July 2017 - 09:35 PM

Nope - never seen this on my several computers. Which module is this - name of file? It may be that the conversion process used some machine translation/conversion and it was not cleaned up. Sometimes modules with such snags are made available so that users can access them as is. Remember they are not paid for free modules they make or convert. As a person making modules I can tell you that it may take many many hours of unpaid work on complicated modules. Contact the module creator and clear that as a possible reason first.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users


This topic has been visited by 25 user(s)